[PHP5 Win] – problem with extension dir – PHP

  php

Q(Question):

I’m configuring PHP5 on my WinXP pro machine as an Apache2 handler.

However when I start apache I get system errormessages like "PHP Shutdown:
Unable to load dynamic library ‘c:\php\ext\php_mcrypt.dll’" for all the
extensions I enabled. I have verified that the extensions indeed exist in
this directory, I’ve changed extension_dir accordingly and I’ve copied them
to my Windows/system32 directory.

What’s going on?
..soma

A(Answer):

"somaBoy MX" <no**@nonesuch.net> ÓÏÏÂÝÉÌ/ÓÏÏÂÝÉÌÁ × ÎÏ×ÏÓÔÑÈ ÓÌÅÄÕÀÝÅÅ:
news:40**********************@news.skynet.be…

I’m configuring PHP5 on my WinXP pro machine as an Apache2 handler.

However when I start apache I get system errormessages like "PHP Shutdown:
Unable to load dynamic library ‘c:\php\ext\php_mcrypt.dll’" for all the
extensions I enabled. I have verified that the extensions indeed exist in
this directory, I’ve changed extension_dir accordingly and I’ve copied
them to my Windows/system32 directory.

What’s going on?
.soma

http://www.php.net/manual/en/install.apache2.php
" Warning
Do not use Apache 2.0 and PHP in a production environment neither on Unix
nor on Windows. "

A(Answer):

"Dennis Biletsky" <uf***@ua.fm> wrote:

http://www.php.net/manual/en/install.apache2.php
" Warning
Do not use Apache 2.0 and PHP in a production environment neither on Unix
nor on Windows. "

First of all: I’m not using this configuration in a production environment
but as a testing environment on my local machine.

Second: I’ve been using PHP 4.2 and upwards as Apache2 handler in this way
for more than a year without any problems…

So I’m quite certain the problem is related to a configuration issue on my
part, rather than a bug in either of the two packages.
..soma

A(Answer):

"somaBoy MX" <no**@nonesuch.net> ÓÏÏÂÝÉÌ/ÓÏÏÂÝÉÌÁ × ÎÏ×ÏÓÔÑÈ ÓÌÅÄÕÀÝÅÅ:
news:40**********************@news.skynet.be…

"Dennis Biletsky" <uf***@ua.fm> wrote:

http://www.php.net/manual/en/install.apache2.php
" Warning
Do not use Apache 2.0 and PHP in a production environment neither on
Unix nor on Windows. "

First of all: I’m not using this configuration in a production environment
but as a testing environment on my local machine.

Second: I’ve been using PHP 4.2 and upwards as Apache2 handler in this way
for more than a year without any problems…

So I’m quite certain the problem is related to a configuration issue on my
part, rather than a bug in either of the two packages.
.soma

Follow the link that I have posted and you can find PHP versions that
compatible with Apache2. There is no PHP5 there.

A(Answer):

"Dennis Biletsky" <uf***@ua.fm> wrote..

Follow the link that I have posted and you can find PHP versions that
compatible with Apache2. There is no PHP5 there.

Why, then, does the PHP5 RC1 package contain the php5apache2.dll file?

..soma

A(Answer):

"somaBoy MX" <no**@nonesuch.net> ÓÏÏÂÝÉÌ/ÓÏÏÂÝÉÌÁ × ÎÏ×ÏÓÔÑÈ ÓÌÅÄÕÀÝÅÅ:
news:40**********************@news.skynet.be…

"Dennis Biletsky" <uf***@ua.fm> wrote..

Follow the link that I have posted and you can find PHP versions that
compatible with Apache2. There is no PHP5 there.

Why, then, does the PHP5 RC1 package contain the php5apache2.dll file?

.soma

I think this question for php developers 🙂 Anyway, I have a very bad
experience with PHP under Apache2, but if you want to use it, so, good luck
🙂

A(Answer):

I do have successfully installed PHP5 with Apache2 on Windows XP without any
problem.
For of all, DONT copy dll to system folder. Leave them where they was, PHP5
will search them on their own directory.
Then I do use php5apache2.dll on Apache conf and worked fine.

Savut

"Dennis Biletsky" <uf***@ua.fm> wrote in message
news:c4***********@fortress.intercom.net.ua…

"somaBoy MX" <no**@nonesuch.net> ÓÏÏÂÝÉÌ/ÓÏÏÂÝÉÌÁ × ÎÏ×ÏÓÔÑÈ ÓÌÅÄÕÀÝÅÅ:
news:40**********************@news.skynet.be…

"Dennis Biletsky" <uf***@ua.fm> wrote..

> Follow the link that I have posted and you can find PHP versions that
> compatible with Apache2. There is no PHP5 there.

Why, then, does the PHP5 RC1 package contain the php5apache2.dll file?

.soma

I think this question for php developers 🙂 Anyway, I have a very bad
experience with PHP under Apache2, but if you want to use it, so, good
luck
🙂

LEAVE A COMMENT